SSL Labs ScoreSecurityHeaders.io Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× EU e-Privacy Directive needs your help!

A free extension like this survives only by reputation. You can help by submitting a review in the Joomla Extension Directory. Please take the time to make a review by clicking on the link below (opens in a new window)

extensions.joomla.org/write-review/review/add?extension_id=4850

Plugin broke website

More
6 months 5 days ago #1341 by deuxbiers
deuxbiers created the topic: Plugin broke website
I've installed the EU Privacy Directive plugin, followed the instructions and now I'm unable to login to the administrator page on my Joomla site!

Any ideas?

Please Log in or Create an account to join the conversation.

More
6 months 5 days ago #1342 by michael
michael replied the topic: Plugin broke website
eprivacy doesn't operate in /administrator.

You can't log in, or you can't stay logged in?

Please Log in or Create an account to join the conversation.

More
6 months 4 days ago #1344 by TheDestroyer
TheDestroyer replied the topic: Plugin broke website
Having the same problem here. Installed the PlugIn/Module, played with it for a few hours and decided it didnt work well with my site. I disabled both plugins and the module and now I'm not able to login to my back-end. When I attempt to login to the backend, there are no errors of any kind, i'm just returned to my logon screen. The same behavior on the front end.

Please Log in or Create an account to join the conversation.

More
6 months 4 days ago #1346 by michael
michael replied the topic: Plugin broke website
That's a neat trick, considering the system plugin has a hardcoded restriction preventing it from running in /administrator.

Line 367:
if ($app->isAdmin())
{
$this->_exit = true;
return true;
}

Please Log in or Create an account to join the conversation.

More
6 months 4 days ago #1347 by deuxbiers
deuxbiers replied the topic: Plugin broke website
I fund the error in the Global Config Settings. When I set the Cookie Domain this is what broke the admin login. So I simply edited the configuration file to remove the cookie domain.
The following user(s) said Thank You: TheDestroyer

Please Log in or Create an account to join the conversation.

More
6 months 3 days ago #1352 by TheDestroyer
TheDestroyer replied the topic: Plugin broke website
Thank you @deuxbiers... this worked for me as well!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum