SSL Labs ScoreSecurityHeaders.io Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× EU e-Privacy Directive needs your help!

A free extension like this survives only by reputation. You can help by submitting a review in the Joomla Extension Directory. Please take the time to make a review by clicking on the link below (opens in a new window)

extensions.joomla.org/write-review/review/add?extension_id=4850

Can't get G-Analytics NC to work

More
1 month 1 day ago #1486 by neilw
neilw created the topic: Can't get G-Analytics NC to work
Using the newest 1.4.8 along with your EU Privacy on a Joomla 2.5.28 site. Removed the normal GA script code from the template's index.php. Installed your plugins (Ajax and System), added the tracking ID, have them enabled. But get nothing on GA. No traffic shows at all.

I tried turning on the debug setting but don't see anything. Hoping to somehow get this to work for our client. Anything else I would need to do?

gurneyenvironmental.com

Thanks.

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #1488 by michael
michael replied the topic: Can't get G-Analytics NC to work
I can't see that the plugin is loaded. None of the javascript files or declarations are present in the homepage source.

It looks like it's still disabled.

I can usually browse to known file locations to confirm that an extension is installed, but you've configured your server to prevent that. That is an excellent security practice that most people don't take the time to do.

Well done!

I attempted to connect to the ajax plugin, and your site responds with a 404, indicating that the ajax plugin is not installed or enabled....something is wrong with the installation.

gurneyenvironmental.com/index.php?option...n&plugin=ganocookies

Have a look at my output, this is what you should see:

www.richeyweb.com/index.php?option=com_a...n&plugin=ganocookies
returns:
{"success":true,"message":null,"messages":null,"data":[false]}

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #1489 by neilw
neilw replied the topic: Can't get G-Analytics NC to work
Both plugins are enabled. Should I perhaps delete them and reinstall?

FYI, we have eprivacy v2.14 installed and working fine, so didn't update that to the newer version. Is that an issue? Always hate to upgrade when finally get something to work!

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #1490 by neilw
neilw replied the topic: Can't get G-Analytics NC to work
Just thought of something. We use Akeeba Admin with their htaccess, so wonder if we need to create an exception for GANC? Had to do that for ExtraWatch, but am thinking it was for their component. I'll take a look at that right now to see what I can spot. Been a while since that was configured, so need to get the cobwebs out of my brain!

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #1491 by neilw
neilw replied the topic: Can't get G-Analytics NC to work
Added these exceptions to the htaccess, but didn't do any good as far as I can tell.

plugins/system/ganocookies/ganocookies.php
plugins/ajax/ganocookies/ganocookies.php

Please Log in or Create an account to join the conversation.

More
1 month 1 day ago #1493 by neilw
neilw replied the topic: Can't get G-Analytics NC to work
Just uninstalled and reinstalled the package. Still no GA results.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum