SSL Labs ScoreSecurityHeaders.io Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× EU e-Privacy Directive needs your help!

A free extension like this survives only by reputation. You can help by submitting a review in the Joomla Extension Directory. Please take the time to make a review by clicking on the link below (opens in a new window)

extensions.joomla.org/write-review/review/add?extension_id=4850

EU e-Privacy Directive not working on my site

More
6 months 1 week ago - 6 months 1 week ago #1758 by smith
smith created the topic: EU e-Privacy Directive
Hi, thanks for the extension!

I cant get it to work. The module gets displayed exactly like on your site but when I click on either button nothing happens. There is no JS error but also no AJAX call as far as I can see in the console. But the console puts out "The EU e-Privacy Directive extension REQUIRES the eprivacy module to be published." but as I mentioned I can see it. Both plug ins are enabled as well. How do I debug that? Thanks.
Last Edit: 6 months 1 week ago by smith.

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #1764 by michael
michael replied the topic: EU e-Privacy Directive
1. Look at the console log to see if there are any javascript errors.
2. Check your ajax component to determine if it's working correctly - Another user contacted me with a similar issue and it turned out to be something in his site that disabled ajax.
going to yoursite.com/?option=com_ajax&format=json - you should see a small JSON structure like {"success":true,"message":null,"messages":null,"data":null}

Let me know what you find, or point me to your site so I can look at it.
The following user(s) said Thank You: smith

Please Log in or Create an account to join the conversation.

More
6 months 1 week ago #1776 by smith
smith replied the topic: EU e-Privacy Directive
Got it sorted. I dont know exactly how but I changed the template position and now it works, thanks.
The following user(s) said Thank You: michael

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum