SSL Labs ScoreSecurityHeaders.io Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× EU e-Privacy Directive needs your help!

A free extension like this survives only by reputation. You can help by submitting a review in the Joomla Extension Directory. Please take the time to make a review by clicking on the link below (opens in a new window)

extensions.joomla.org/write-review/review/add?extension_id=4850

Cookie loads even with disabled checkmark

More
3 months 5 days ago #2004 by Swooty
Swooty created the topic: Cookie loads even with disabled checkmark
Hey Michael,

I added a cookie javascript into a module and set the module to 'cookie' user only. As long as the cookies are not accepted they are not loading. So all works as wanted.

The problem is that if I do not checkmark the cookie and accept, they still gets loaded to the page. So its not set to require and the user should have the choice to load it that way or not?

I really hope you can help me soon. -> mann-und-gesundheit.com/

Greetings,
Chris

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #2006 by michael
michael replied the topic: Cookie loads even with disabled checkmark
The cookie is loaded - but the module is not - did I understand that correctly?

If this is the case, I just released 3.10.6 with a provision to remove cookies set for specific levels on the hosting domain

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago - 3 months 5 days ago #2010 by Swooty
Swooty replied the topic: Cookie loads even with disabled checkmark
The module is loading well and also the cookies with the new update.

So when i enable (checkmark) the not required cookie for the analytics get loaded.
If I not enable (checkmark) the not required cookie for the analytics it gets not loaded.

The problem is that they not get removed when I uncheck it after i accepted it one time and press accept again.

So I tested regex with \b_pk_\b, \_pk_\gm, \_pk_\g as i found on google and it does not remove the cookies.

Also the full name of the cookie as string seems not to work to get them removed.

The cookies are loaded to the main domain without a dot.
Attachments:
Last Edit: 3 months 5 days ago by Swooty.

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #2011 by michael
michael replied the topic: Cookie loads even with disabled checkmark
Javascript Regex is a little different.....

Since they all begin with _pk_, you can simply enter "^_pk_" (without quotes) and choose the type as Regex. It will match anything beginning with _pk_.

The domain should be "mann-und-gesundheit.com" and the path should be "/" (again, no quotes) - from what I see in your config, this all looks OK. Just fix the regex and you'll be golden.

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago - 3 months 5 days ago #2013 by Swooty
Swooty replied the topic: Cookie loads even with disabled checkmark

I changed the regex to "^_pk_" without quotes but get the same result attached the image and on the page you can see that they not get removed when unchecked :/

Thanks for your help.
Attachments:
Last Edit: 3 months 5 days ago by Swooty.

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #2017 by michael
michael replied the topic: Cookie loads even with disabled checkmark
"without quotes" does not mean "surround it with slashes instead"

You entered "/^_pk_/" into the field, when you should have entered "^_pk_"

Javascript handles adding the delimiters and escaping control characters.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum