SSL Labs ScoreSecurityHeaders.io Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× EU e-Privacy Directive needs your help!

A free extension like this survives only by reputation. You can help by submitting a review in the Joomla Extension Directory. Please take the time to make a review by clicking on the link below (opens in a new window)

extensions.joomla.org/write-review/review/add?extension_id=4850

v3.10.8 javascript error

More
3 months 4 days ago #2056 by luX0r.reload
luX0r.reload created the topic: v3.10.8 javascript error
Hi,
with newer versions and some older browsers (eg. Firefox 43) I've one Javascript error:

SyntaxError: missing ; before statement

With previous version no errors appears with Firefox 43 too.

Please Log in or Create an account to join the conversation.

More
3 months 4 days ago #2064 by michael
michael replied the topic: v3.10.8 javascript error
I keep undoing modernization efforts to support obsolete browsers.... This is the result of an IE11 modification, now I must downgrade again to support FF43 (which reached end-of-life January 2016)

The problem is that FF (apparently) doesn't support the "let" variable assignment. So, I've removed it and it will be part of the 3.10.10 release - probably sometime this week.

Please Log in or Create an account to join the conversation.

More
3 months 4 days ago #2096 by luX0r.reload
luX0r.reload replied the topic: v3.10.8 javascript error
I know this is a big problem cause many users still using older browsers.
So for fix this error I can modify js code to remove let declaration?

Please Log in or Create an account to join the conversation.

More
3 months 3 days ago - 3 months 3 days ago #2099 by michael
michael replied the topic: v3.10.8 javascript error
I already released the update. It's done - just upgrade to the latest version, which is 3.10.11

Since GDPR went live, I get bug reports all the time. I don't let them sit around. They get fixed immediately. I had a couple of new reports last night, and a few new versions were released to resolve them.
Last Edit: 3 months 3 days ago by michael.

Please Log in or Create an account to join the conversation.

More
3 months 3 days ago #2102 by luX0r.reload
luX0r.reload replied the topic: v3.10.8 javascript error
Just upgraded. Clean joomla cache and browser cache but in FF43 cookie banner doesn't appears cause there are two new js error:

SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data
SyntaxError: JSON.parse: unexpected character at line 1 column 1 of the JSON data

Please Log in or Create an account to join the conversation.

More
3 months 3 days ago #2103 by michael
michael replied the topic: v3.10.8 javascript error
FF 43 can't handle element.innerText....pity

Maybe that's why they end-of-life'd it in 2016

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum