SSL Labs ScoreSecurityHeaders.io ScoreHSTS Preloaded

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× EU e-Privacy Directive needs your help!

A free extension like this survives only by reputation. You can help by submitting a review in the Joomla Extension Directory. Please take the time to make a review by clicking on the link below (opens in a new window)

extensions.joomla.org/write-review/review/add?extension_id=4850

v3.10.8 javascript error

More
1 year 9 months ago #2104 by michael
Replied by michael on topic v3.10.8 javascript error
I just spent some time looking up browser usage by version, and users on firefox prior to version 52 represent less than 0.19% of usage....the records don't get more detailed than that - so uses on firefox 43 are a fraction of a fraction of 1%

Modern firefox doesn't have the same issues.

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #2111 by luX0r.reload
Can I have link to this statistics? I want to verify browser versions for Italy (target for my site).
FF43 use textContent instead of innerText.

Previous versions of your ePrivacy plugin works fine for me, I tested it some weeks ago and it works with FF43 too.
Eventually have you a copy of old versions?

Thanks

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #2112 by michael
Replied by michael on topic v3.10.8 javascript error
clicky.com/marketshare/global/web-browsers/firefox/

caniuse.com/usage-table
ranks FF 43 at 0.03% market share

www.w3schools.com/BROWSERS/browsers_firefox.asp
FF43 hasn't seen above 1% usage since April 2016

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #2114 by luX0r.reload
Thanks.
I'm reading innerText is not supported in FF till version 46.
So stats must include several versions and not only 43.
Your extension is great, so if the problems with these browser versions is only innerText why no implementing feature detection to switch off between .textContent and .innerText?

developer.mozilla.org/en-US/docs/Web/API/Node/textContent

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #2115 by michael
Replied by michael on topic v3.10.8 javascript error
Do you have some specific reason that compels you to use browsers that reached end-of-life 2 years ago? 46 reached end-of-life June 7, 2016

Mozilla doesn't even support these browsers anymore.

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #2116 by danielecr
Replied by danielecr on topic v3.10.8 javascript error
I can understand your point of view, if your statistics show that "some users" visit your site with older browsers; however system administrators should be responsible and move forward, espacially if operating systems and softwares are no more supported by the developers, mostly because of security!

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Powered by Kunena Forum