SSL Labs ScoreSecurityHeaders.io Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× EU e-Privacy Directive needs your help!

A free extension like this survives only by reputation. You can help by submitting a review in the Joomla Extension Directory. Please take the time to make a review by clicking on the link below (opens in a new window)

extensions.joomla.org/write-review/review/add?extension_id=4850

Experience getting the Plugin to Work with the helix framework

More
5 months 2 weeks ago #2214 by Websitecreator2018
Websitecreator2018 created the topic: Experience getting the Plugin to Work with the helix framework
Hello there, i will say right of the bat that i am unfortunately rather inexperienced in working with joomla.
For use with my private site i aquired a Template from Joomshaper which is based on the helix framework, unfortunately i cant use the system Message option ( as stated in the documentation this is likely due to the z Axis in the Template ) and the framework ( which is apparently geared more towards inexperienced users like myself) is not supporting the use of modal windows (other than a few predifined ones)

I was wondering if anyone has already managed to get this (amazing) plugin to work with that particular Framework.

best regards!

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #2215 by michael
michael replied the topic: Experience getting the Plugin to Work with the helix framework
Look at your template and determine if you have this code present:

<jdoc:include type="message" />

If you don't have it, your template designer did not include the possibility for system messages in the template.

This is pretty common with poorly designed templates.

Fortunately, an easy fix is to locate the component code, and inject the message code directly above it. Most templates display the system message directly above the component output, so this is usually pretty safe.

<jdoc:include type="component" /> <-- find this, and inject the message code (above) above it.
The following user(s) said Thank You: Websitecreator2018

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago - 5 months 2 weeks ago #2217 by Websitecreator2018
Websitecreator2018 replied the topic: Experience getting the Plugin to Work with the helix framework
Thank you for your prompt response.

The Message component is present and properly displayed, it's just that when interacting with the buttons nothing happens, i tried injecting the message code above , the message got displayed however the buttons still could not interact, thus i assumed it was the issue with the "z-value" you referred to in your documentation.
the only display method that does work is the module itself, that however is of course not particulaly elegant from an esthetic viewpoint.

You can have a look at the project site via the following link, however i urge you to only do so in case you are interested from a development standpoint as i am fully expecting for this to be a layer 8 issue, i really would not want to steal your time on this.

www.velimirovic.at/home

(It's currently set to display both in the template message position and above)
Last Edit: 5 months 2 weeks ago by Websitecreator2018.

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #2218 by michael
michael replied the topic: Experience getting the Plugin to Work with the helix framework
Looking at it now - That is quite strange

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #2219 by michael
michael replied the topic: Experience getting the Plugin to Work with the helix framework
I've switched gdpr.richeyweb.com to use the system message display method - and it's working as expected.

Something I notice with your site - the plugin is working, but it's not reloading the page when cookies are accepted. I'm still looking at it, trying to determine where it fails.

Please Log in or Create an account to join the conversation.

More
5 months 2 weeks ago #2220 by michael
michael replied the topic: Experience getting the Plugin to Work with the helix framework
Did you create the accepted/declined cookie groups/access levels?

Your site never sends a cookie - even after accepting them. This is usually indicative of a misconfiguration and the most common is the cookie access levels.

The vars passed to the plugin are mostly empty - the plugin is mostly unconfigured (other than the defaults). It looks like it was installed, and enabled - but never opened and configured. For example, the policy URL and lawlink options are empty - which isn't possible unless the plugin configuration was never saved.

This is not a plug-and-play extension. It requires preparation and configuration.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum