SSL Labs ScoreSecurityHeaders.io ScoreHSTS Preloaded

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× Extension Discussions

Favicon component worked perfectly until I upgraded PHP

More
1 year 7 months ago #570 by AndreB1404
Unfortunately, there are more deprecated methods, so it still does not work for PHP7. It now reports the following:
Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP
/com_favicon/helpers/floIcon.php on line 222
com_favicon/helpers/floIcon.php on line 356
Regards...Andre

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #571 by michael
I wasn't looking for errors in the component, so I guess it's for the best that the package installer was borked.

OK, so I repaired the floicon class to resolve the deprecation errors on 222 and 356 as well as fixing the installer package xml file.

Version 1.22 is available for download...and I tested the installer this time....just to be sure I didn't forget another renamed file in the xml.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #572 by AndreB1404
Tx Michael but the download is still 1.2.1 on your site.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #573 by AndreB1404
Ignore, it has now gone to 1.2.2 Tx

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #574 by AndreB1404
Going out of town now, so will test when I get back on Thursday...Tx

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #586 by AndreB1404
Hi Michael, I have installed version 1.2.2. Install Package working fine but I get a white screen on my Joomla Admin back-end when I try to create a new icon (clicking on the +Create button). The strange thing is that although I have Error reporting set to Maximum, I do not get an error display this time around like before. According to the "experts" this could be caused by a Plugin or Component overriding the System setting but I have no clue where to look.
Maybe there are still more deprecated methods lower down in your component?
I will keep on trying to get an error message out of the system but I am running out of ideas.
Regards...Andre

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Powered by Kunena Forum