SSL Labs ScoreSecurityHeaders.io ScoreHSTS Preloaded

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× Extension Discussions

sessionkeeper only works on admin side

More
1 year 7 months ago #714 by racmitch
i installed your "sessionkeeper" plugin on a sandbox site. I shows a timeout warning on the admin side but not on the front end to users. I do understand that having an active "log in" module disables it from working, but I have disabled the log in in the main menu on the page I'm testing and still do not get the warning. I do get the warning on the admin side, which is strange because the joomla admin log in is in the menu on those pages? Any ideas, using joomla 3.8.5 php 7.0

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #715 by michael
The plugin looks for the system keepalive active on each page. If the page has a keepalive - it won't display a timeout message because the user will never timeout.

If you have a login module visible on every page of your site - then every page of your site has an active keepalive.

To test this out, modify your login module to NOT appear on a particular page. then hang out on that page to see the message.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #716 by michael
I think I'll modify the plugin to report a message to the error console if there's an active keepalive on the page. Then on the plugin page here on my site, I'll post a link to information about how to look at the error log for various browsers.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #719 by kurtboeker
Sorry but I'm having the same problem. Latest version of Joomla 3.8.5, and I just bought your plugin (again) yesterday. It works on the admin side but not on the front end. I do get logged out. But there's no warning, and it does not redirect to the menu I select.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago - 1 year 7 months ago #720 by kurtboeker
Yes I have unassigned the login module on one page, and I hang out there and nothing happens. I set my session time ans advanced warning time to 6 minutes / 3 minutes. I also completely removed the older version of your plugin. I am using a Yootheme template. session handler is Database. shared sessions is no.
Last edit: 1 year 7 months ago by kurtboeker.

Please Log in or Create an account to join the conversation.

More
1 year 7 months ago #721 by michael
OK, both of you - if you could please either post your website so I can have a look at it - or use the contact menu at the top of the page to email me your website info if you don't want it public.

There are 3 reasons for the plugin to NOT give the warning.

1. the page has a keepalive present
2. the logged in user is a member of a keepalive group configured in the plugin
3. a javascript error preventing the plugin from running

Also, a screenshot of your plugin configuration please.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to edit your message.
Powered by Kunena Forum