SSL Labs ScoreSecurityHeaders.io Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× Extension Discussions

Custom Field Location only showing long/lat

More
9 months 3 weeks ago #2526 by michael
michael replied the topic: Custom Field Location only showing long/lat
Sorry, I'm at a point in development on a customer project where I need this to function again. So you'll see progress this coming week.

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #3859 by andygaskell
andygaskell replied the topic: Custom Field Location only showing long/lat
I had a problem that sounds similar to this, the map was not showing in the view.

For me it was caused by a jQuery error....

The console it had...
ReferenceError: jQuery is not definedplg_fields_location.min.js:7:1
http://localhost/outdoorlearning/media/plg_fields_location/plg_fields_location.min.js?f517c273ec4e298d6afb2edf080e07e8:7

So I guess there is a template dependency on jQuery, I was just using the default Protostar in Joomla! 3.9.8.

I added...
JHtml::_('jquery.framework',true);
...to the...
plugins/fields/location/tmpl/location.php
...file, and that fixed it.

Thanks for making this plugin, it's really nice, and works well :)

Please Log in or Create an account to join the conversation.

More
3 weeks 1 day ago #3860 by andygaskell
andygaskell replied the topic: Custom Field Location only showing long/lat
Sorry, just reading back I realise my reply is maybe not really related to the issue in the thread at all. Hope it might be helpful anyway.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum