SSL Labs Score

Log in to participate

There is no cost to join RicheyWeb, and membership is a requirement to submit bug reports and participate in the support forums.

× Extension Discussions

Browser Update Warning

More
1 year 1 month ago #121 by michael
michael created the topic: Browser Update Warning
Browser Update Warning {arslatest release Browser Update Warning}
Overview
Set (and optionally require)...

Browser Update Warning 1.7

Overview

Set (and optionally require) minimum browser versions for your site. Using this plugin, you can display a warning message that the users browser is outdated, along with a suggestion that they update (or install) a browser that meets your requirements.

Using this plugin, you can choose minimum version numbers for the major browsers. These are the browsers supported by this plugin:

  • Internet Explorer
  • Safari
  • Firefox
  • Chrome
  • Opera

Users who don't meet the minimum requirements are shown a modal window suggesting that they update their current browser, or install a new browser - complete with download links! NOTE: You must enable each browser you wish to provide links to - by checkboxes located in the plugin configuration. By default - only the current browser is offered as a download option.

Administrators can enforce these minimum requirements by disabling the "Continue" option, which forces the users to meet the requirements by keeping the site just out of reach behind the modal window.

Aside from version and continue options, administrators can choose to use the default styling or provide their own styling via their template CSS, choose to disable the background overlay, and set the opacity of the background overlay.

For those with multilingual sites, all of the text is set by Joomla language files so you won't be leaving anyone behind.

This plugin is 100% MooTools, so it doesn't require any additional javascript libraries. It makes use of the BrowserUpdateWarning MooTools plugin by Andy Fleming with some of my own modifications to allow for multilingual sites.

The Demo site URL has very high (non-existent) version numbers set, so it will display for all users using the targeted browsers.

 

Installation

  1. Download Browser Update Warning from the RicheyWeb download page.  
    • This page will remain unlinked, as the link may change in the future.  Visit http://www.richeyweb.com and use the search feature - search for "Browser Update Warning".
  2. In Joomla /administrator, go to the "Extensions" menu, the "Manage" sub-menu, and the "Install" sub-menu.
  3. Select the "Upload Package File" tab
  4. Press the "Choose File" button to browse your system and locate the plugin file you downloaded
  5. Press the "Upload & Install" button

At this point, the extension is installed but not enabled.  You can find the plugin by going to the Extensions menu and selecting "Plugins".  When in the plugin manager, search for "Browser Update Warning".  

 

Configuration

Hide on Mobile
Options: Yes (both), No, Only Phones, Only Tablets
Shaded Overlay

Options: Yes, No

Use a shaded overlay on the content when displaying the warning modal.

Shade Opacity
Numeric percentage of opacity used on the overlay. Number ONLY, do not include the percent (%) symbol
Allow Continue
Allow users who do not meet minimum requirements to continue.
Browser Options
Enable/disable individual browser tests: Internet Explorer, Safari, Firefox, Chrome and Opera.
Minimum Versions
Version tests - minimum versions: Internet Explorer, Safari, Firefox, Chrome and Opera.
Use Plugin CSS
Option to include/omit the plugin CSS stylesheet. If set to no, the modal must be styled using other means.
 

HELP

Please submit bug reports if you have any issue.

Please Log in or Create an account to join the conversation.

  • Not Allowed: to create new topic.
  • Not Allowed: to reply.
  • Not Allowed: to add attachements.
  • Not Allowed: to edit your message.
Kunena Forum